Uso do JBoss 4, 5 e 6

De Wiki Integrator do Brasil
Ir para: navegação, pesquisa

As versões do servidor Java JBoss 4, 5 e 6 não estão disponíveis no suporte a hospedagem padrão da Integrator, cujo servidor JBoss 7, Wildfly 8, 9 ou 10 são recomendados para uso.
Entretanto, caso o usuário necessite destas versões antigas, em máquinas virtuais somente, o Integrator Java EE tem suporte para instalação e uso. Porém, pedimos que perca alguns minutos para os seguintes problemas encontrados nas versões antigas:

1. O JBoss 4 e 5 possuem problemas de vulnerabilidade nestes serviços:

  • web-console: [ VULNERABLE ]
  • jmx-console: [ VULNERABLE ]
  • JMXInvokerServlet: [ VULNERABLE ]


2. O JBoss 6 possui vulnerabilidade neste serviço:

  • JMXInvokerServlet: [ VULNERABLE ]


A Integrator possui especialistas em segurança que podem configurar uma ferramenta em sua máquina virtual, sem custo, para que possa testar. Em todas as situações, o ideal é migrar para uma versão mais atual. Na impossibilidade de tal situação, nossa recomendação é remover os referidos aplicativos padrão listados:

  • web-console.war
  • http-invoker.sar
  • jmx-console.war
  • jmx-invoker-adaptor-server.sar
  • admin-console.war




IMPORTANTE: O suporte da Integrator não recomenda o uso de versões antigas e não se responsabiliza por eventuais problemas de segurança que vier a ter. Os referidos servidores não possuem mais atualizações de segurança por seus idealizadores.