Instalando e Configurando o Firebird em Máquinas com cPanel em VPS

De Wiki Integrator do Brasil
Ir para: navegação, pesquisa

Para instalar e configurar o banco de dados Firebird em um VPS, com cPanel, siga os passos abaixo. É necessário acesso SSH e acesso ao root da máquina.

Índice

Instalando o Firebird

1. Baixe o RPM:

yum install http://dl.fedoraproject.org/pub/epel/6/x86_64/epel-release-6-8.noarch.rpm

2. Instale:

yum install firebird-superclassic firebird-devel

3. Inicie:

/etc/init.d/firebird-superclassic start


Para configurar, o arquivo firebird.conf se encontra em:

/etc/firebird/firebird.conf


Os arquivos do firebird ficam em:

/etc/rc.d/init.d/firebird-superclassic
/usr/sbin/fb_smp_server
/usr/share/doc/firebird-superclassic-2.5.5.26952.0/

Iniciando como serviço

Execute o comando abaixo para que o serviço do Firebird seja iniciado automaticamente caso reinicie seu VPS:

chkconfig --level 345 firebird-superclassic on

Para compilar o EasyApache4 para trabalhar com o PHP

O EasyApache 4 é uma versão nova, disponível em máquinas cloud virtuais com cPanel à partir da data de Julho/2016 em diante. Se sua máquina é anterior a esta data, possivelmente está na versão do EasyApache 3.
Os passos necessários para compilar a extensão do Firebird/Interbate no PHP:
1. Entre no SSH e veja qual a versão corrente na máquina:

php -v

2. Baixe a versão source no site oficial do PHP em http://php.net/downloads.php.
Para simplificar, vamos exemplificar o uso da versão do PHP 5.5.38:

wget -O php-5.5.38.tar.gz  http://ca2.php.net/get/php-5.5.38.tar.gz/from/this/mirror

3. Descompacte:

tar xvf  php-5.5.38.tar.gz

4. Configure:

cd php-5.5.38/ext/interbase/
/opt/cpanel/ea-php55/root/usr/bin/phpize
./configure --with-interbase=/etc/firebird --with-php-config=/opt/cpanel/ea-php55/root/usr/bin/php-config

Nos passos 2 a 4, cabe uma observação. O EasyApache 4 possui várias versões do PHP e cada qual em um caminho, onde o php-config pode variar de versão, assim como phpsize:

  • PHP 5.4:
/opt/cpanel/ea-php54/root/usr/bin/phpize
/opt/cpanel/ea-php54/root/usr/bin/php-config
  • PHP 5.5:
/opt/cpanel/ea-php55/root/usr/bin/phpize
/opt/cpanel/ea-php55/root/usr/bin/php-config
  • PHP 5.6:
/opt/cpanel/ea-php56/root/usr/bin/phpize
/opt/cpanel/ea-php56/root/usr/bin/php-config
  • PHP 7.0:
/opt/cpanel/ea-php70/root/usr/bin/phpize
/opt/cpanel/ea-php70/root/usr/bin/php-config
  • PHP 7.1:
/opt/cpanel/ea-php71/root/usr/bin/phpize
/opt/cpanel/ea-php71/root/usr/bin/php-config


5. Compile:

make

6. Instale:

cp modules/interbase.so  /opt/cpanel/ea-php55/root/usr/lib64/php/modules/

7. Configure o PHP.INI:

echo "extension=interbase.so" >  /opt/cpanel/ea-php55/root/etc/php.d/interbase.ini 

Nos passos 6 e 7, muda o comando a cada versão do PHP que for instalar o módulo:

  • PHP 5.4:
/opt/cpanel/ea-php54/root/usr/lib64/php/modules/
/opt/cpanel/ea-php54/root/etc/php.d/interbase.ini 
  • PHP 5.5:
/opt/cpanel/ea-php55/root/usr/lib64/php/modules/
/opt/cpanel/ea-php55/root/etc/php.d/interbase.ini 
  • PHP 5.6:
/opt/cpanel/ea-php56/root/usr/lib64/php/modules/
/opt/cpanel/ea-php56/root/etc/php.d/interbase.ini 
  • PHP 7.0:
/opt/cpanel/ea-php70/root/usr/lib64/php/modules/
/opt/cpanel/ea-php70/root/etc/php.d/interbase.ini 
  • PHP 7.1:
/opt/cpanel/ea-php71/root/usr/lib64/php/modules/
/opt/cpanel/ea-php71/root/etc/php.d/interbase.ini 


8. Reinicie o Apache:

/scripts/restartsrv_apache

9. Teste a compilação após o término:

php -m |grep interbase

Para compilar o EasyApache3 para trabalhar com o PHP

1. Crie o arquivo abaixo:

echo "--with-interbase=/etc/firebird" > /var/cpanel/easy/apache/rawopts/all_php5

2. Compile:

/scripts/easyapache

3. Teste a compilação após o término:

php -m |grep interbase



IMPORTANTE: Este tutorial não possui suporte da Integrator. O Firebird não faz parte do portfólio oficial da hospedagem e quaisquer perguntas a respeito de seu uso serão ignorados.